NATIVE VLAN LÀ GÌ

     

Có những các loại VLAN nào, nhắc tên những loại Vlan 

Một trong số những khái niệm mà nhiều người nhầm lẫn khi học mạng, quản lí trị mạng thường gặp. Đó đó là Có những nhiều loại VLAN như thế nào ? Native vlan là gì ? nội dung bài viết này Kho ứng dụng Soft Folder vẫn giải đáp thắc mắc đó cho chúng ta ! Hãy khám phá trong bài viết sau !

Khái niệm Vlan là gì

Có 2 cách nhìn về VLAN

Nhìn trên một Switch

VLAN là một switch logical (ta bao gồm ổ cứng 80GB thứ lý tạo thành ổ C, D, E. Những ổ logical này là độc lập). Các VLAN hòa bình sẽ ko Forwarding thanh lịch VLAN khác. VLAN sẽ không tồn tại bảng MAC của riêng nó nhưng mà nó áp dụng chung bảng MAC của Switch đồ dùng lý. Switch đồ gia dụng lý sẽ xây dựng dựng bảng MAC như sau:

VLANMACCổngVLANMACCổngVLANMACCổng
100.0c.0aF0/1200.0c.0nF0/11300.0c.n1F0/16
100.0c.05F0/2200.0b.0dF0/12300.0c.n2F0/17
100.0c.09F0/3200.0c.06F0/13300.0c.n3F0/18
100.0c.00F0/4200.0c.08F0/14300.0c.n4F0/19

Trên một Switch đồ vật lý chia thành 3 VLAN là VLAN 1, VLAN 2, VLAN 3. Sau khi chia thì 3 VLAN sẽ tương xứng là 3 Switch độc lập. Trên một Switch 24 cổng ta có VLAN 1 tất cả cổng từ 1-10, VLAN 2 bao gồm cổng tự 11-15, VLAN 3 có cổng trường đoản cú 16-24. Các máy làm việc VLAN 1 sẽ không còn trao thay đổi được với các máy ở VLAN 3 vày 2 VLAN này tương ứng 2 Switch độc lập.Bạn đã xem: Native vlan là gì


*

Vlan là gì – tư tưởng Vlan

+ quan sát trên cả một hệ thống: VLAN là 1 Boroadcast domain.

Bạn đang xem: Native vlan là gì

Xét trên 2 Switch đồ dùng lý:

+ từng Switch phân thành 3 VLAN như thể nhau. Bề ngoài là VLAN 1 của SW1 thông VLAN 1 của SW2, VLAN 2 của SW1 thông VLAN 2 của SW2, VLAN 3 thông VLAN 3.

SW1SW2
VLAN1VLAN1
VLAN2VLAN2
VLAN3VLAN3

+ Để VLAN 1 thông cùng nhau thì trên SW1 cắn dây vào một trong những cổng VLAN 1 kết nối sang cổng thuộc VLAN 1 của SW2, tương tự với VLAN2 cùng 3.

+ từng VLAN sẽ khớp ứng một mạng độc lập nên gọi là một trong Broadcast domain.

Tại sao phải chia VLAN (Virtual Local Area Network)

Xét khối hệ thống bình thường

Một công ty giáo dục thuê một tòa nhà có nhiều tầng. Tầng 1 là khối văn phòng có một Switch (đây call là mạng LAN khối văn phòng bao hàm cả nhân viên tư vấn). Tầng 2 là phòng giám đốc đặt một Switch, Tầng 3 giảng viên để một Switch, tầng 4, 5 là của sinh viên. Toàn bộ các tầng hầu như nối ra Router cùng ra internet. Tuy vậy vào mùa tuyển chọn sinh thì số lớp vẫn ít nhưng support viên buộc phải nhiều (khối văn phòng đưa lên một ít tại tầng 4 với 5).

Phòng giám đốc đề xuất thu thon lại để nhường chống khác, tuy thế phòng ban giám đốc lại chỉ tất cả 3 hoặc 4 bạn thì quá ra không hề ít cổng. Hệ thống sẽ gồm sự tốn kém khi gồm thiết bị cụ đổi.

Do cả tòa nhà cùng Router và đi ra internet nên cùng sử dụng một dải mạng, và một Broadcast domain. Khối hệ thống sẽ không tồn tại độ bảo mật thông tin cao giữa những phòng ban. Khi bị vi khuẩn thì cả hệ thống rất có thể bị lây lan. Khi gồm một người đứng trong mạng có thể bắt được hết toàn bộ gói tin toàn mạng trải qua Router.

Trong một doanh nghiệp có thực hiện nhiều yếu tắc và vận dụng vào hệ thống mạng như: cần sử dụng Voice IP, truy cập Web, Mail, truy vấn dữ liệu trong hệ thống. Nếu bình thường thì ko có gì nhưng không may bị ùn tắc thì vẫn lỗi cả hệ thống.


*

Vì sao cần phải chia VlanXét khối hệ thống có thiết bị cung ứng VLAN

Vẫn các Switch do đó nhưng khi sử dụng VLAN nó chỉ cần kéo một dây từ bỏ Router về một Switch như thế nào đó, sau đó sẽ phân chia VLAN

Trên một Switch 24 cổng nếu cung cấp VLAN thì nó sẽ chia nhỏ tuổi khu vực một giải pháp hợp lý: VLAN 1 gồm cổng từ bỏ 1-10, VLAN 2 có cổng trường đoản cú 11-15, VLAN 3 tất cả cổng từ bỏ 16-24.

Có các loại Vlan nào 

VLAN một là gì

Đây là hình dáng mạng mang định của tất tất cả các thiết bị chuyển mạch cung cấp VLAN với nó hoạt động ở Lớp 2 (Data liên kết layer) trong mô hình OSI của hệ thống. Vày vậy nếu khối hệ thống mạng thứ tính của khách hàng được thiết bị một thiết bị chuyển mạch có hỗ trợ công dụng này mà bạn chưa cấu hình thiết lập các thông số kỹ thuật kỹ thuật thì mang định nó vẫn rất có thể chuyển tiếp những gói dữ liệu giữa các máy vi tính và thiết bị liên kết vào nó một cách thông thường như những thiết bị chuyển mạch khác. Vì bây giờ tất cả những cổng mạng bên trên thiết bị gửi mạch mặc định đều nằm trong cùng một miền tiếp thị và cùng với sự quản lý của VLAN 1.

Xem thêm: Daesang Là Gì ? Daesang Bao Gồm Những Phần Thưởng Nào? Ý Nghĩa, Phân Loại Giải Thưởng Trong Kpop

Trong VLAN 1 có rất nhiều giao thức sinh hoạt Lớp 2 vận động giao tiếp với nhau như: CDP, PagP, VTP; đề xuất đây đó là lý do nguyên nhân VLAN 1 được lựa chọn làm giao diện mạng khoác định và rất dễ thấy trên các thiết bị mạng có hỗ trợ tính năng chia mạng ảo của Cisco System.

Default VLAN là gì

Là hình trạng VLAN khoác định ban đầu với tất cả các cổng giao tiếp trên thiết bị chuyển mạch. Bởi vậy default VLAN cũng rất có thể hiểu là VLAN 1, và những VLAN khác như User VLAN, Native VLAN, Management VLAN đầy đủ là những thành phần bé của default VLAN.

User VLAN (hay Data VLAN) 

Là VLAN trong số ấy chứa các tài khoản người dùng thành từng đội dựa theo các thuộc tính về quánh thù công việc của từng nhóm thao tác hay theo nằm trong tính về địa chỉ vật lý của những nhóm thao tác này.

Native VLAN là gì 

Native VLAN là 1 VLAN được thực hiện để cấu hình Trunking do một số thiết bị không tương thích với nhau. Lúc 1 cổng của switch được cấu hình trunk, vào phần tag của frame trải qua cổng đó sẽ được thêm một số trong những hiệu VLAN mê thích hợp.

Tất cả các frames thuộc những VLAN khi trải qua đường trunk sẽ được gắn thêm những tag của giao thức 802.1q và ISL, nước ngoài trừ các frame của VLAN 1. Như vậy, theo mặc định các frames của VLAN 1 khi trải qua đường trunk sẽ không được thêm tag.

Native VLAN hoàn toàn có thể được đưa thành VLAN khác bởi câu lệnh như sau :

Switch(config-if)#switchport trunk native vlan vlan-id

Lưu ý : đối với Native VLAN chúng ta không đề xuất sử dụng như thể user VLAN tuyệt management VLAN.

Management VLAN là gì

Để rất có thể giám ngay cạnh từ xa các thiết bị gửi mạch trong khối hệ thống mạng của mình, bạn cần phải có một VLAN đặc biệt quan trọng dùng để thực hiện việc này, đó chính là Management VLAN. Bằng phương pháp gán một showroom IP dùng để telnet tự xa vào hệ thống mạng thông qua địa chỉ cửa hàng IP này, và rất có thể cấm các người dùng khác truy cập vào thiết bị.

Vì đó là một VLAN hơi nhạy cảm được cấp một số quyền cai quản trị phải nó rất cần phải được tách bóc riêng ra khỏi các VLAN khác để đảm bảo an toàn yếu tố bình yên bảo mật. Khi mạng có sự việc như: quy tụ với STP, broadcast storms thì một Management VLAN được cho phép nhà cai quản trị vẫn có thể truy cập được vào sản phẩm công nghệ và giải quyết vấn đề đó.

Cấu hình địa chỉ IP cho Switch

Switch#config terminal

Switch(config)#interface vlan vlan-id

Switch(config-if)#ip address xxx.xxx.xxx.xxx subnet mask

Switch(config-if)#end

Địa chỉ này sẽ được sử dụng để quản trị Switch từ bỏ xa (qua telnet). Xxx.xxx.xxx.xxx là địa chỉ IP của VLAN. Ví dụ: 192.168.10.2 lấy ví dụ như subnet mask là 255.255.255.0

Voice VLAN là gì

Voice VLAN là VLAN dành cho lưu lượng thoại. Nó chất nhận được các cổng Switch mang lưu lượng thoại IP tự một điện thoại cảm ứng IP. Người quản trị mạng cấu hình một Voice VLAN và gán nó để truy vấn các cổng. Lúc một điện thoại cảm ứng thông minh IP được liên kết với những cổng Switch, Switch vẫn gửi gói tin CDP đó lý giải các điện thoại cảm ứng thông minh IP gắn kèm để gửi lưu lượng thoại được gán nhãn VLAN ID.

Xem thêm: Bài 3 Trang 114 Sgk Tiếng Việt Lớp 4, Người Đi Săn Và Con Vượn Trang 113

Một số câu lệnh thông số kỹ thuật VLAN hay gặp

Câu lệnh để tên mang đến VLAN

SW(config)# Vlan 2

SW(config-vlan)# name IT

SW(config-vlan)# exit

Câu lệnh gán cổng mang lại VLAN

SW(config)# interface range f0/1-5

SW(config-if-range)#switchport access vlan 2

Cậu lệnh Gán Trunking cho cổng

+ Đối với cái 2900 nó cung cấp sẵn dot1Q yêu cầu không yêu cầu bật. Chỉ việc vào cổng nhảy Trunk lên là xong

SW(config)# interface f0/24

SW(config-if)#switchport mode trunk

+ Đối với dòng 3500 trở lên buộc phải vào bật dot1Q tuyệt ISL nó mới chạy. Còn nếu không bật sẽ báo lỗi:

SW(config)# interface f0/24

SW(config-if)#switchport trunk encapsulation SW(config-if)#switchport mode trunk

Chú ý: thường gán cổng trunk chạy sang trọng Switch không giống hoặc về Router.

Câu lệnh Gán Native VLAN vào VLAN cai quản lý

SW(config)# Vlan 100

SW(config-vlan)# name Managerment

SW(config-vlan)# exit

SW(config)# interface f0/24 (phải tất cả 2 lệnh)

SW(config-if)#switchport access vlan 100

SW(config-if)#switchport native vlan 100

SW(config-if)#exit

SW(config)#interface vlan 100

SW(config-if)#ip địa chỉ 192.168.1.1 255.255.255.0

Cấu hình trên thực tiễn về VLAN1, VLAN NATIVE, VLAN default trên cùng VLAN1

SW0(config)#interface vlan 1

SW0(config-if)#ip showroom 11.0.0.254 255.255.255.0

SW0(config-if)#no shut

SW0(config-if)#exit

SW1(config)#interface vlan 1

SW0(config-if)#ip showroom 11.0.0.253 255.255.255.0

SW0(config-if)#no shut

SW0(config-if)#exit

CORE(config)#interface f0/0.1

CORE(config-subif)#encapsulation dot1Q 1

CORE(config-subif)#ip địa chỉ cửa hàng 11.0.0.1 255.255.255.0

CORE(config-subif)#exit

Trên tất cả các sản phẩm công nghệ đều phải kê mật khẩu

SW(config)#line console 0

SW(config-line)#password abc

SW(config-line)#login

SW(config-line)#exit

SW(config)#line vty 0 4

SW(config-line)#password abc

SW(config-line)#login

SW(config-line)#exit

SW(config)#enable secret cisco

Trên PC cần sử dụng lệnh: telnet 11.0.0.x để truy cập từ xa

Các lệnh chất vấn vlan thường xuyên gặp

SW(config)# Show vlan

SW(config)# Show vlan brief

SW(config)# Show interfaces trunk

SW(config)# Show mac-address-table

chú ý: file cấu hình VLAN để trong bộ nhớ lưu trữ flash là: vlan.dad. Không lưu giữ trong file Running config