Ospf Là Gì

     

OSPF – mở cửa Shortest Path First là 1 trong những giao thức định tuyến link – state điển hình. Đây là 1 trong giao thức được sử dụng rộng rãi trong những mạng công ty lớn có size lớn. Mỗi router khi chạy giao thức vẫn gửi các trạng thái đường links của nó cho toàn bộ các router vào vùng (area). Sau một thời gian trao đổi, những router sẽ nhất quán được bảng cơ sở tài liệu trạng thái đường liên kết (Link State Database – LSDB) cùng với nhau, mỗi router đều phải sở hữu được phiên bản đồ mạng của cả vùng. Từ đó mỗi router đã chạy giải mã Dijkstra giám sát và đo lường ra một cây lối đi ngắn độc nhất (Shortest Path Tree) và phụ thuộc vào cây này để xây hình thành bảng định tuyến.

Bạn đang xem: Ospf là gì

1. Links State

Link State là giao thức xây cất đường đi cực tốt (Shortest path first) thông qua giải thuật Dijkstra. Các router chỉ việc trao đổi tin tức của nhau qua gói tin Hello nhưng không buộc phải gửi cả bảng định tuyến. Sau khoản thời gian có thông tin nó sẽ xây dựng ra một bảng định đường và con đường đi xuất sắc nhất.

Chỉ số AD: là chỉ số tin yêu của các giao thức

Cost: là giá chỉ trị được xem theo bí quyết 10^8/Bandwidth

OSPF chạy trên nền IP còn RIP điều khiển xe trên giao thức UDP

Các gói tin IP vận chuyện các gói tin OSPF thì ngôi trường Protocol- ID = 89

2. Cơ chế buổi giao lưu của giao thức OSPF

Router chạy theo OSPF thì nó buộc phải trải qua 4 bước:

Router ID

Thiết lập Neighbor

Trao đổi LSDB (Link State Database)

Xây dựng bảng định tuyến

a. Router ID là gì ?

Router IDđơn giản là một trong những giá trị sử dụng định danh đến Router khi dùng giao thức OSPF

Có định hình của một địa chỉ cửa hàng IP A.B.C.D. Gồm định dạng là địa chỉ IP chứ chưa phải là add IP

Lấy IP cao nhấttrong cácInterface vẫn hoạt độngvàưu tiên cổng Loopback.

+ IP cao nhất: là địa chỉ cửa hàng IP cao nhất. IP bao gồm octet đầu cao hơn nữa được xem như là lớn hơn

Vd: 1, 192.168.1.1,

2, 192.168.1.2, => là lớn nhất (xét từ 192, kế tiếp sang 168 kế tiếp sang 1 và ở đầu cuối là 2)

3, 172.16.255.255,

4, 10.255.255.254.

Địa chỉ 2 > 1 > 3 > 4

Vậy ID của Router ở đây là 192.168.1.2

+ Interface active: là cổng đã (up/up) Status up với protocol up.

+ Cổng Loopback sẽ tiến hành ưu tiên hơn bởi nó không nhiều bị hỏng và ổn định.

b. Cấu hình thiết lập quan hệ trơn giềng

Các Router sẽ gửi gói tin Hello (10s/1 lần). Được dùng để tìm ra router nhẵn giềng, đưa một quan hệ giới tính láng giềng sang trọng trạng thái 2 bước (2- Way), tiếp đến Hello giúp đo lường láng giếng lúc nó bị lỗi.

Lần trước tiên gói tin Hello gởi tới địa chỉ 224.0.0.6

2 Router phải thỏa mãn các đk sau bắt đầu được hotline là trơn giềng (phải bảo vệ 5 thông tin):

=> cùng Area-id: lúc mạng lớn bạn ta chia làm nhiều vùng, vùng nào hỏng thì chỉ vùng đó chịu đựng tác động. Mỗi một vùng vẫn đặt cho một Area-id. Vùng trung tâm gồm Area-id phải bởi 0. Phần đa vùng khác phải gồm đường truyền thẳng về vùng 0 nó bắt đầu truyền được dữ liệu.

=> cùng Subnet: 2 ip yêu cầu cùng Subnet new ping và hiệp thương được thông tin.

=> buộc phải cùng thông số: Hello/Dead-time nghỉ ngơi trên 2 cổng. Mang định Hello là 10s, Dead là 40s sau 40s nó sẻ hủy kết nối.

=> đề xuất cùng tuyệt đối trên 2 cổng. Dành cho mạng khủng (metro). Lúc đặt xác thực các router không giống không rước được thông tin.

=> đề xuất cùng cờ Stub Area Flag: giành cho OSPF nhiều vùng (học vào CCNP)

Để xem được sản phẩm xóm dùng lệnh: Show IP OSPF Neighbor

c. Hiệp thương LSDB (Link State Database)

Mỗi Router những chưa một bảng LSDB

LSDP: links State Database. Vày nó lớn vì thế nó chia nhỏ dại ra thành các bản LSA để gửi

LSA: links State Advertisement. Để gởi được LSA thì nó buộc phải đóng gói vào bản tin LSU

LSU: là liên kết State Update. Để dàn xếp và gởi được LSU thì nó gồm 2 kiểu môi trường xung quanh gửi:

- Point - lớn - Point: 2 router chạy với nhau theo giao thức HDLC hayPPP. Sau khoản thời gian nó liên kết được láng giềng thì chỉ tất cả 2 Router trao đổi trực tiếp gọi là Full

- Broadcast Multiaccess: là những Router liên kết với nhau thông sang 1 Swtich. R1, R2, R3, R4 cùng liên kết vào 1 Switch. Bây giờ nó hội đàm LSDB sẽ khác hoàng toàn.

Trong 4 Router sẽ thai ra một Router có tác dụng DR-Desigted Router, 3 router còn sót lại sẽ thai ra một BDR-Backup DR.

Các Router còn lại sẽ là DR Other. 2 Router là DR Other sẽ không gửi thẳng với nhau. Nó vẫn gửi tin tức về DR 1 bạn dạng và 1 bản cho BDR. Tiếp nối DR đã gửi trưng bày xuống cho những Router còn lại.

DR Other vẫn gử thông tin về DR bằng add 224.0.0.6. DR đã gửi LSDB đến DR Other là 224.0.0.5.

Xem thêm: Top 7 Bài Cảm Nhận Về Người Đàn Bà Hàng Chài (8 Mẫu), Please Wait

Tiêu chí như thế nào được thai làm DR và BDR:

Trên từng cổng kết nối của những Router sẽ sở hữu một tham số: Priority(0-255) mang định là 1. Nhỏ nào tối đa là DR và nhỏ nào thấp rộng là BDR.

Câu lệnh: R(config)# int F0/1 => R(config -if)# ip ospf priority (0-255)

Nếu rủi ro có Priority là đều bằng nhau nó sẽ phụ thuộc Router - ID. Router có Router-id cao nhất là DR

Nếu khối hệ thống đã bao gồm DR với BDR nếu cắm thêm một Router mới tất cả DR cao hơn nó vẫn ưu tiên DR đã hoạt động.

Nếu để Priority là 0 nó sẽ không còn bầu DR hay BDR

c. Chế tạo bảng định đường nó dùng lời giải Dijkstra để đưa ra đường đi giỏi nhất

3. Phương pháp tính Metric

Cost=10^8 /bandwidth

Băng thông yêu cầu đổi ra đối chọi vị: bps

Vd:

*

4. Cấu hình

a. Wildcard mask

Wildcard masklà một cách thức lấy ra showroom IP của một dải rất linh thiêng hoạt. Nó là một trong những dãy nhị phân 32 bit được dùng kèm cùng với một địa chỉ cửa hàng IP tham chiếu nào đó. Bit của showroom IP tương xứng với Bit 0 là vắt định, bit của IP tương xứng với bit 1 sẽ cầm định.

Vd: 192.168.1.0/24

Ta có: IP:192.168.1.0

WCM: 0 . 0 . 0.255

Vd: 192.168.1.32/27

Ta có: IP: 192.168.1.001xxxxx

WCM: 0 . 0 . 0 .00011111 => 0.0.0.31

b. Những lệnh cấu hình

Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ có ý nghĩa sâu sắc nội bộ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là cùng mạng yếu tố này rất quan trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

Hiệu chỉnh OSPF

Router - ID:

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IP đó là ID)

Sau kia trở ra mode quản trị:

R(config)# Clear ip ospf process thì nó mới gồm hiệu lực

Priority:

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time:

R(config-if)# ip ospf hello-interval thời hạn (là giây)

R(config-if)# ip ospf dead-interval thời gian (là giây)

Xác thực bên trên 2 router

Vào trong cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

5. Chú ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.20, 00:00:53, Serial0/1/0 => tương xứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.20, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate

II.Single-area với Multi-area OSPF

1. Cấu hình Single-area OSPF

a. Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ có chân thành và ý nghĩa nội bộ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là cùng mạng nhân tố này siêu quan trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

b. Hiệu chỉnh OSPF

Router - ID

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IP đó là ID)

Sau kia trở ra mode quản trị:

R(config)# Clear ip ospf process thì nó mới có hiệu lực

Priority

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time

R(config-if)# ip ospf hello-interval thời hạn (là giây)

R(config-if)# ip ospf dead-interval thời hạn (là giây)

c. Xác xắn trên 2 router

Vào vào cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

d. Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

2. Cấu hình Multi-area OSPF

a. Cấu hình Multi-area

Router(config)#router ospf 5

Router(config-router)#redistribute ospf 10 subnet

b. Redistribute vào OSPF

RIP => OSPF

Router(config)#router ospf process-id

Router(config-router)#redistribute rip subnet.

EIGRP-OSPF

Router(config-router)#redistribute eigrp as-number subnet.

Static route và Default route => OSPF

Router(config-router)#redistribute static subnet.

Connected route => EIGRP

Router(config-router)#redistribute connected subnet.

Default route => OSPF

Router(config-router)#default-information originate.

Nếu bọn họ không đưa vào thông số metric thì mang định metric sẽ tiến hành đặt mang đến tuyến được redistribute vào là 20.

Xem thêm: Công Dụng Của Dụng Cụ Cơ Khí Là Gì? Bộ Dụng Cụ Cơ Khí Gồm Những Loại Nào?

3. Chú ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.20, 00:00:53, Serial0/1/0 => tương xứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.20, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate